Archiwa kategorii: Network

Brute force ssh login

apt-get install sshpass

Hasło zawierało 2 cyfry z shiftem oraz 4 stałe znaki

#!/bin/bash
TAB=("!" "@" "#" "$" "%" "^" "&" "*" "(" ")");
for (( i=0; $i <= 9; i++ )) ; do
for (( j=0; $j <= 9; j++ )) ; do
      PSS=${TAB[$i]}${TAB[$j]}"xxxx";
      echo $PSS;
sshpass -p "$PSS" ssh ubnt@10.10.197.77 
done
done

Konfiguracja OLT Huawei dla OSE

vlan 5 smart
port vlan 5 0/9 0
vlan attrib 5 q-in-q
interface giu 0/9
jumbo-frame 0 enable

GAMS(config)#vlan service-profile profile-id 22 profile-name MDO

GAMS(config-vlan-srvprof-22)#forwarding vlan-connect
Info: Please use the commit command to make modifications take effect

GAMS(config-vlan-srvprof-22)#bpdu tunnel enable
Info: Please use the commit command to make modifications take effect

GAMS(config-vlan-srvprof-22)#commit

GAMS(config)#vlan bind service-profile 5 profile-id 22
Binding will last for several minutes, please do not delete the VLAN.

GAMS(config)#ont-srvprofile gpon profile-id 22 profile-name MdO-szkola

GAMS(config-gpon-srvprofile-22)#ont-port pots adaptive eth adaptive
{ |catv|moca|tdm-srvtype|tdm-type|tdm|vdsl }:

Command:
ont-port pots adaptive eth adaptive

GAMS(config-gpon-srvprofile-22)#port vlan eth 1 transparent
Set ONT port(s) VLAN configuration, success: 1, failed: 0

GAMS(config-gpon-srvprofile-22)#commit

GAMS(config-gpon-srvprofile-22)#quit

GAMS(config)#ont-lineprofile gpon profile-id 22 profile-name MdO-szkola

GAMS(config-gpon-lineprofile-22)#tcont 1 dba-profile-id 10

GAMS(config-gpon-lineprofile-22)#mapping-mode port

GAMS(config-gpon-lineprofile-22)#gem add 1 eth tcont 1
{ |cascade|downstream-priority-queue|encrypt|gem-car|priority-queue }:

Command:
gem add 1 eth tcont 1

GAMS(config-gpon-lineprofile-22)#gem mapping 1 0 eth 1
{ |flow-car|priority|transparent|vlan }:

Command:
gem mapping 1 0 eth 1

GAMS(config-gpon-lineprofile-22)#commit

ont add 10 22 sn-auth 48575443A1xxxxxx omci ont-lineprofile-id 22 ont-srvprofile-id 22 desc MdO-Szkola25
service-port vlan 5 gpon 0/0/10 ont 22 gemport 1 multi-service user-vlan 10 tag-transform translate-and-add inner-vlan 800
service-port vlan 5 gpon 0/0/10 ont 22 gemport 1 multi-service user-vlan 11 tag-transform translate-and-add inner-vlan 801
service-port vlan 5 gpon 0/0/10 ont 22 gemport 1 multi-service user-vlan 12 tag-transform translate-and-add inner-vlan 802
service-port vlan 5 gpon 0/0/10 ont 22 gemport 1 multi-service user-vlan 51 tag-transform translate-and-add inner-vlan 803
service-port vlan 5 gpon 0/0/10 ont 22 gemport 1 multi-service user-vlan 52 tag-transform translate-and-add inner-vlan 804
service-port vlan 5 gpon 0/0/10 ont 22 gemport 1 multi-service user-vlan 101 tag-transform translate-and-add inner-vlan 805
service-port vlan 5 gpon 0/0/10 ont 22 gemport 1 multi-service user-vlan 102 tag-transform translate-and-add inner-vlan 806

dlink DGS-1510-28X firmware upgrade

Przez http wgrać plik z firmware, a potem:

Switch#dir

Directory of /c:
1 -rw 8655864 Jan 01 2000 00:13:59 runtime.had
2 -rw 9962856 Jan 01 2000 00:18:13 1_50_021
3 -rw 22821 Jan 01 2000 00:07:25 config.cfg
4 -rw 9791996 Jan 01 2000 00:31:54 1_60_012
5 d– 0 Jan 01 2000 00:00:08 system

30656000 bytes total (1528832 bytes free)

Switch#configure
Switch#configure terminal
Switch(config)#boot image 1_60_012
Switch(config)#end
Switch#reboot

Are you sure you want to proceed with the system reboot?(y/n)

Zapisanie konfiguracji w tym pliku robi się tak:
Switch#copy running-config startup-config

Destination filename startup-config? [y/n]: y

Saving all configurations to NV-RAM………. Done.

Switch#reboot

Are you sure you want to proceed with the system reboot?(y/n)

OLT Huawei – syslog i monit

OLT Huawei’a potrafi wysyłać logi poprzez syslog po UDP.

Aby włączyć zdalne słuchanie sysloga w Linuksie w rsyslog należy odremować linie w /etc/rsyslog.conf:
$ModLoad imudp
$UDPServerRun 514

Dobrze dodać aby log z OLT szedł do innego pliku, robi się to dodając do /etc/rsyslog.conf na początku reguł linie:

if $fromhost-ip startswith ‚10.11.x.’ then /var/log/olt.log
& ~

(gdzie 10.11.x to podsieć w której jest OLT. Ta druga linia oznacza, że ma już pozostałych reguł nie przechodzić, i nie zapisywać ponownie)

W OLT ustawiamy:
syslog enable alarm-event
loghost add 10.11.x.x log_server
loghost activate ip 10.11.x.x

gdzie 10.11.x.x to serwer rsyslogd

Teraz możemy skonfigurować monit, który będzie nas informował o problemach. W /etc/init.d/monitrc ustawiamy:

set mailserver localhost
set mail-format { from: monit@email.moj
subject: $SERVICE $EVENT at $DATE
message: Monit $ACTION $SERVICE at $DATE on $HOST: $DESCRIPTION.
Yours sincerely,
monita
check file olt.log with path /var/log/olt.log
if match „FAULT”
then alert
if match „RECOV”
then alert

Można bardziej szczegółowo ustawić informowanie, np.
if match „fiber is broken” lub „LOSi/LOBi” i będziemy dostawać emaile w przypadku prawdopodobnego ucięcia światłowodów do klientów, a o mniej istotnych informacjach nie.

mikrotik jako PIM router do telewizji (multicast)

/interface vlan
add interface=ether1 name=internet vlan-id=13
add interface=ether1 name=stb vlan-id=401
add interface=ether1 name=transmisja vlan-id=3700
/ip address
add address=192.168.x.50/29 interface=transmisja network=192.168.x.48
add address=172.16.5.2/24 interface=internet network=172.16.5.0
add address=10.1.1.1/24 interface=stb network=10.1.1.0
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip firewall nat
add action=src-nat chain=srcnat out-interface=internet src-address=10.1.1.0/24 to-addresses=172.16.5.2
/ip route
add distance=1 gateway=172.16.5.1
add distance=1 dst-address=10.10.1.x/32 gateway=192.168.x.49
add distance=1 dst-address=10.100.y.0/24 gateway=192.168.x.49
add distance=1 dst-address=192.168.176.0/22 gateway=192.168.x.49
/routing pim
set switch-to-spt-interval=30s
/routing pim interface
add interface=stb
add interface=transmisja
/routing pim rp
add address=10.100.110.z

Nie konfiguruję dhcp, gdyż adresy rozdaje linux 10.1.1.2 w vlanie 401.

Dlaczego nie cisco? Docelowo tak będzie. Mikrotik bierze mniej prądu, na razie wystarcza.
Chciałem użyć do tego OLT Huawei MA5683T, ale wydaje się, że nie ma w nim PIM SM.

Podstawowa konfiguracja OLT Huawei MA5683T (SCUN)

defaultowy IP 10.11.104.2 login: root hasło: admin
(backspace działa po wciśnięciu CTRL-H)

#display board 0
————————————————————————-
SlotID BoardName Status SubType0 SubType1 Online/Offline
————————————————————————-
0 H805GPFD Normal
1
2
3
4
5
6 H802SCUN Active_normal
7 H802SCUN Standby_normal
8 H801GICF Normal
9 H801X2CS Normal
10
11
12
————————————————————————-

Jeśli któraś z kart nie ma statusu Normal, trzeba ją dodać, np.
config
board add board add 0/0 H805GPFD
board confirm 0/0

Aktualną konfigurację pokazuje:
#display current-configuration

Interfejsem do zarządzania (wyłącznie) jest meth, ustawiamy mu IP:
config
interface meth 0
ip address 172.16.20.1 255.255.255.0
save

Dodajemy VLAN:
config
vlan 300
port vlan 300 0/8 0 (300 to numer VLAN, 8 to karta GICF (zgodnie z display board 0), 0 to pierwszy port)
Możemy ustawić IP na VLANie:
interface vlanif301
ip address 10.10.20.2 255.255.255.0

Ustawiamy autofind na każdym porcie, na którym chcemy aby ONTy zostawały znajdowane:
interface gpon 0/0
port 0 ont-auto-find enable
port 1 ont-auto-find enable

Poniższą komendą można wylistować nieskonfigurowane nowe ONTy:
(config-if-gpon-0/0)#display ont autofind 0
Failure: The automatically found ONTs do not exist
(nie należy podpinać bezpośrednio ONT do OLT, bo sygnał będzie za mocny i ONT nie będzie widoczny, po podłączeniu jednego splittera 1×16 działa)

Dodajemy ONTa:
GAMS(config-if-gpon-0/0)#ont add 1 12 sn-auth „4857544306xxxxxx” omci ont-lineprofile-id 0 ont-srvprofile-id 1 desc „HG850aKK”
Number of ONTs that can be added: 1, success: 1
PortID :1, ONTID :12

GAMS(config-if-gpon-0/0)#display ont info 1 12
—————————————————————————–
F/S/P : 0/0/1
ONT-ID : 12
Control flag : active
Run state : online
Config state : normal
Match state : match
DBA type : SR
ONT distance(m) : 1554
ONT battery state : not support
Memory occupation : –
CPU occupation : –
Temperature : –
Authentic type : SN-auth
SN : 4857544306xxxxxx (HWTC-06D7E510)
Management mode : OMCI
Software work mode : normal
Isolation state : normal
ONT IP 0 address/mask : –
Description : HG850a BG112
Last down cause : –
Last up time : 2017-10-02 21:52:18+08:00
Last down time : –
Last dying gasp time : –
ONT online duration : 0 day(s), 0 hour(s), 0 minute(s), 20 second(s)
Type C support : Not support
Interoperability-mode : ITU-T
—————————————————————————–
VoIP configure method : Default
—————————————————————————–
Line profile ID : 0
Line profile name : line-profile_default_0
—————————————————————————–
FEC upstream switch :Disable
OMCC encrypt switch :Off
Qos mode :GEM-CAR
Mapping mode :VLAN
TR069 management :Disable
TR069 IP index :0
—————————————————————————–
Notes: * indicates Discrete TCONT(TCONT Unbound)
—————————————————————————–
DBA Profile-ID:2
DBA Profile-ID:20
—————————————————————————–
Service profile ID : 1
Service profile name : ont-default
—————————————————————————–
Port-type Port-number
—————————————————————————–
POTS 2
ETH 4
VDSL 0
TDM 0
MOCA 0
CATV 0
—————————————————————————–
TDM port type : E1
TDM service type : TDMoGem
MAC learning function switch : Enable
ONT transparent function switch : Disable
Ring check switch : Disable
Ring port auto-shutdown : Enable
Ring detect frequency : 8 (pps)
Ring resume interval : 300 (s)
Multicast forward mode : Unconcern
Multicast forward VLAN : –
Multicast mode : Unconcern
Upstream IGMP packet forward mode : Unconcern
Upstream IGMP packet forward VLAN : –
Upstream IGMP packet priority : –
Native VLAN option : Concern
Upstream PQ color policy : –
Downstream PQ color policy : –
—————————————————————————–
Port-type Port-ID QinQmode PriorityPolicy Inbound Outbound
—————————————————————————–
ETH 1 unconcern unconcern unconcern unconcern
ETH 2 unconcern unconcern unconcern unconcern
ETH 3 unconcern unconcern unconcern unconcern
ETH 4 unconcern unconcern unconcern unconcern
—————————————————————————–
Notes: * indicates the discretely configured traffic profile,
run the display traffic table ip command to query
traffic table configuration.
—————————————————————————–
Port-type Port-ID DownstreamMode MismatchPolicy
—————————————————————————–
ETH 1 operation discard
ETH 2 operation discard
ETH 3 operation discard
ETH 4 operation discard
—————————————————————————–
Port-type Port-ID Dscp-mapping-table-index
—————————————————————————–
ETH 1 0
ETH 2 0
ETH 3 0
ETH 4 0
IPHOST 1 0
—————————————————————————–
Port-type Port-ID IGMP-mode IGMP-VLAN IGMP-PRI Max-MAC-Count
—————————————————————————–
ETH 1 – – – Unlimited
ETH 2 – – – Unlimited
ETH 3 – – – Unlimited
ETH 4 – – – Unlimited
—————————————————————————–
Alarm policy profile ID : 0
Alarm policy profile name : alarm-policy_0
—————————————————————————–

Najprostsza jest konfiguracja ‚simplified’, tzn. bez ręcznego przydzielania gemportów:

service-port 1012 vlan 300 port 0/0/0 ont 12 iphost multi-service user-vlan 300 tag-transform translate
(do VLANu 300 na OLT, dodajemy końcówkę klienta (ONT) u niego też VLAN 300.
Zmiana hasła:
#terminal user password
User Name(<=15 chars):root Old Password(<=15 chars): New Password(length<8,15>):
Failure: The password must contain at least one digit
New Password(length<8,15>):
Confirm Password(length<8,15>):
Information takes effect
Repeat this operation? (y/n)[n]:n

DGS 1510 enable telnet

Switch(config)#line telnet
Switch(config-line)#password nowehaslo

Switch(config)#username admin password nowehaslo

Switch(config)#enable password nowehaslo

Switch(config)#ip telnet server

dla ssh podobnie:

Switch(config)#ip enable server

ale trzeba wygenerować klucz.

UBNT Compliance Test jak włączyć?

Trzeba zalogować się przez ssh na ubnt@192.168.1.20 i dalej:

touch /etc/persistent/ ct
sed -i 's/radio.1.countrycode=616/radio.1.countrycode=511/g' /tmp/system.cfg
sed -i 's/radio.countrycode=616/radio.countrycode=511/g' /tmp/system.cfg
sed 's/radio.1.dfs.status=.*$/radio.1.dfs.status=disabled/g' -i /tmp/system.cfg
save
reboot

 

 

 

 

 

 

UBNT: Supervisory, Receiver not Ready

Nanostation LOCO M5 jako station, łączy się z AP, ale nie odpowiada na pingi, widać tcpdumpem:

11:19:16.086330 00:15:6d:e6:e4:XX > ff:ff:ff:ff:ff:ff Null Supervisory, Receiver not Ready, rcv seq 64, Flags [Poll], length 46
11:19:16.086346 00:15:6d:e6:e4:XX > ff:ff:ff:ff:ff:ff Null Unnumbered, xid, Flags [Response], length 46: 01 02

Pomaga restart zdalny.